CRAN Package Check Results for Package piecepackr

Last updated on 2020-10-26 11:51:12 CET.

Flavor Version Tinstall Tcheck Ttotal Status Flags
r-devel-linux-x86_64-debian-clang 1.5.1 18.44 233.19 251.63 OK
r-devel-linux-x86_64-debian-gcc 1.5.1 13.15 168.55 181.70 OK
r-devel-linux-x86_64-fedora-clang 1.5.1 295.93 OK
r-devel-linux-x86_64-fedora-gcc 1.5.1 290.47 OK
r-devel-windows-ix86+x86_64 1.5.1 28.00 267.00 295.00 OK
r-patched-linux-x86_64 1.5.1 17.22 240.23 257.45 OK
r-patched-solaris-x86 1.5.1 363.00 OK
r-release-linux-x86_64 1.5.1 16.32 239.17 255.49 OK
r-release-macos-x86_64 1.5.1 OK
r-release-windows-ix86+x86_64 1.5.1 18.00 215.00 233.00 OK
r-oldrel-macos-x86_64 1.5.1 ERROR
r-oldrel-windows-ix86+x86_64 1.5.1 25.00 254.00 279.00 ERROR

Check Details

Version: 1.5.1
Check: examples
Result: ERROR
    Running examples in ‘piecepackr-Ex.R’ failed
    The error most likely occurred in:
    
    > ### Name: piecepackr-deprecated
    > ### Title: Deprecated functions
    > ### Aliases: piecepackr-deprecated halmaGrob kiteGrob pyramidGrob
    > ### convexGrobFn concaveGrobFn gridlinesGrob matGrob checkersGrob
    > ### hexlinesGrob get_shape_grob_fn
    >
    > ### ** Examples
    >
    > if (require("grid")) {
    + suppressWarnings({
    + gp <- gpar(col="black", fill="yellow")
    + pushViewport(viewport(x=0.25, y=0.75, width=1/2, height=1/2))
    + grid.draw(get_shape_grob_fn("rect")(gp=gp))
    + grid.draw(gridlinesGrob("blue", lex=4))
    + grid.draw(hexlinesGrob("green"))
    + popViewport()
    +
    + pushViewport(viewport(x=0.75, y=0.75, width=1/2, height=1/2))
    + grid.draw(get_shape_grob_fn("convex6")(gp=gp))
    + grid.draw(checkersGrob("blue", shape="convex6"))
    + popViewport()
    +
    + pushViewport(viewport(x=0.25, y=0.25, width=1/2, height=1/2))
    + grid.draw(get_shape_grob_fn("circle")(gp=gp))
    + grid.draw(matGrob("blue", shape="circle", mat_width=0.2))
    + popViewport()
    +
    + pushViewport(viewport(x=0.75, y=0.25, width=1/2, height=1/2))
    + grid.draw(get_shape_grob_fn("rect")(gp=gp))
    + grid.draw(matGrob("blue", shape="rect", mat_width=c(0.2, 0.1, 0.3, 0.4)))
    + popViewport()
    +
    + grid.newpage()
    + gp <- gpar(col="black", fill="yellow")
    +
    + vp <- viewport(x=1/3-1/6, width=1/3)
    + grid.draw(halmaGrob(gp=gp, vp=vp))
    + vp <- viewport(x=2/3-1/6, width=1/3)
    + grid.draw(pyramidGrob(gp=gp, vp=vp))
    + vp <- viewport(x=3/3-1/6, width=1/3)
    + grid.draw(kiteGrob(gp=gp, vp=vp))
    +
    + grid.newpage()
    + vp <- viewport(x=1/4, y=1/4, width=1/2, height=1/2)
    + grid.draw(convexGrobFn(3, 0)(gp=gp, vp=vp))
    + vp <- viewport(x=3/4, y=1/4, width=1/2, height=1/2)
    + grid.draw(convexGrobFn(4, 90)(gp=gp, vp=vp))
    + vp <- viewport(x=3/4, y=3/4, width=1/2, height=1/2)
    + grid.draw(convexGrobFn(5, 180)(gp=gp, vp=vp))
    + vp <- viewport(x=1/4, y=3/4, width=1/2, height=1/2)
    + grid.draw(convexGrobFn(6, 270)(gp=gp, vp=vp))
    +
    + grid.newpage()
    + vp <- viewport(x=1/4, y=1/4, width=1/2, height=1/2)
    + grid.draw(concaveGrobFn(3, 0, 0.1)(gp=gp, vp=vp))
    + vp <- viewport(x=3/4, y=1/4, width=1/2, height=1/2)
    + grid.draw(concaveGrobFn(4, 90, 0.2)(gp=gp, vp=vp))
    + vp <- viewport(x=3/4, y=3/4, width=1/2, height=1/2)
    + grid.draw(concaveGrobFn(5, 180, 0.3)(gp=gp, vp=vp))
    + vp <- viewport(x=1/4, y=3/4, width=1/2, height=1/2)
    + grid.draw(concaveGrobFn(6, 270)(gp=gp, vp=vp))
    + }, classes = "deprecatedWarning")
    + }
    Loading required package: grid
    Error in suppressWarnings({ :
     unused argument (classes = "deprecatedWarning")
    Execution halted
Flavors: r-oldrel-macos-x86_64, r-oldrel-windows-ix86+x86_64

Version: 1.5.1
Check: tests
Result: ERROR
     Running ‘run-all.R’ [95s/95s]
    Running the tests in ‘tests/run-all.R’ failed.
    Last 13 lines of output:
     Loading required package: piecepackr
     ── 1. Error: grob_fn_helpers works as expected (@test-deprecated.R#7) ─────────
     unused argument (classes = "deprecatedWarning")
     Backtrace:
     1. vdiffr::expect_doppelganger(...)
     2. vdiffr:::writer(fig, testcase, title)
     4. vdiffr:::print_plot.function(plot, title)
     5. piecepackr:::p()
    
     ══ testthat results ═══════════════════════════════════════════════════════════
     [ OK: 173 | SKIPPED: 102 | WARNINGS: 84 | FAILED: 1 ]
     1. Error: grob_fn_helpers works as expected (@test-deprecated.R#7)
    
     Error: testthat unit tests failed
     Execution halted
Flavor: r-oldrel-macos-x86_64

Version: 1.5.1
Check: tests
Result: ERROR
     Running 'run-all.R' [160s]
    Running the tests in 'tests/run-all.R' failed.
    Complete output:
     > library("testthat")
     >
     > test_check("piecepackr")
     Loading required package: piecepackr
     -- 1. Error: grob_fn_helpers works as expected (@test-deprecated.R#7) ---------
     unused argument (classes = "deprecatedWarning")
     Backtrace:
     1. vdiffr::expect_doppelganger(...)
     2. vdiffr:::writer(fig, testcase, title)
     4. vdiffr:::print_plot.function(plot, title)
     5. piecepackr:::p()
    
     == testthat results ===========================================================
     [ OK: 178 | SKIPPED: 101 | WARNINGS: 28 | FAILED: 1 ]
     1. Error: grob_fn_helpers works as expected (@test-deprecated.R#7)
    
     Error: testthat unit tests failed
     Execution halted
Flavor: r-oldrel-windows-ix86+x86_64